[You are not allowed to use len() and sum()] Hint (1): For taking dictionary input Approach(1): For taking dictionary as an input from the user, you may take the whole dictionary as a string using the input() function. Then you can use the spit(), strip() functions and conditions to get the keys and values from the string. Finally, you can make the dictionary using the obtained data. Approach(2): If the first approach seems too difficult you can create an empty dictionary and then just run a simple loop. For each iteration ask the user for a key and a value using the input() function and keep updating the dictionary with the key and value. Hint (2): After you have a dictionary, you can use dictionary functions to get all the values from it, run loop to calculate the sum and the total number of values in the dictionary in order to find out the average. Sample Input 1: (Jon': 100, 'Dan':200, 'Rob:300} Sample Output 1: Average is 200. Sample Input 2: {Jon': 100, 'Dan':200, 'Rob':30, 'Nedď":110} Sample Output 2:

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question
Downloads/
E ID-21201491;NAME-Nuzhat Taba x
+
English
O localhost:8888/notebooks/Downloads/ID-21201491%3BNAME-Nuzhat%20Tabassum%20%3Bsec-17%20%3B%20CSE110.ipynb
Cjupyter ID-21201491;NAME-Nuzhat Tabassum ;sec-17 ; CSE110 Last Checkpoint: 6 minutes ago (autosaved)
Logout
File
Edit
View
Insert
Cell
Kernel
Widgets
Help
Trusted
Python 3 O
+
> Run
с
Markdown
Write a Python program that takes a dictionary as an input from the user and then prints the average of all the values in the dictionary.
[You are not allowed to use len() and sum()]
Hint (1): For taking dictionary input
Approach(1): For taking dictionary as an input from the user, you may take the whole dictionary as a string using the input() function. Then you can use the
split(), strip() functions and conditions to get the keys and values from the string. Finally, you can make the dictionary using the obtained data.
Approach(2): If the first approach seems too difficult you can create an empty dictionary and then just run a simple loop. For each iteration ask the user for a
key and a value using the input() function and keep updating the dictionary with the key and value.
Hint (2): After you have a dictionary, you can use dictionary functions to get all the values from it, run loop to calculate the sum and the total number of values
in the dictionary in order to find out the average.
Sample Input 1:
{'Jon': 100, 'Dan':200, 'Rob':300}
Sample Output 1:
Average is 200.
Sample Input 2:
{'Jon': 100, 'Dan':200, 'Rob':30, 'Ned':110}
Sample Output 2:
Average is 110.
11:18 PM
11/29/2021
Transcribed Image Text:Downloads/ E ID-21201491;NAME-Nuzhat Taba x + English O localhost:8888/notebooks/Downloads/ID-21201491%3BNAME-Nuzhat%20Tabassum%20%3Bsec-17%20%3B%20CSE110.ipynb Cjupyter ID-21201491;NAME-Nuzhat Tabassum ;sec-17 ; CSE110 Last Checkpoint: 6 minutes ago (autosaved) Logout File Edit View Insert Cell Kernel Widgets Help Trusted Python 3 O + > Run с Markdown Write a Python program that takes a dictionary as an input from the user and then prints the average of all the values in the dictionary. [You are not allowed to use len() and sum()] Hint (1): For taking dictionary input Approach(1): For taking dictionary as an input from the user, you may take the whole dictionary as a string using the input() function. Then you can use the split(), strip() functions and conditions to get the keys and values from the string. Finally, you can make the dictionary using the obtained data. Approach(2): If the first approach seems too difficult you can create an empty dictionary and then just run a simple loop. For each iteration ask the user for a key and a value using the input() function and keep updating the dictionary with the key and value. Hint (2): After you have a dictionary, you can use dictionary functions to get all the values from it, run loop to calculate the sum and the total number of values in the dictionary in order to find out the average. Sample Input 1: {'Jon': 100, 'Dan':200, 'Rob':300} Sample Output 1: Average is 200. Sample Input 2: {'Jon': 100, 'Dan':200, 'Rob':30, 'Ned':110} Sample Output 2: Average is 110. 11:18 PM 11/29/2021
Expert Solution
steps

Step by step

Solved in 3 steps with 2 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY